OE 5 und 6-FAQ > 2.10 Warum werden Mails/News gar nicht oder nur als Attachments angezeigt?

1.0 Vorbemerkung/Warnhinweis
1.01 Welche Einstellungen sollte ich vornehmen?
1.02 Was sollte ich vor dem Posten beachten?
1.03 Ist meine OE-Version auf dem aktuellsten Stand?
1.04 Änderungen an OE durch aktuelle Updates

2.0 Warum...
2.01 Warum setzt OE beim Antworten das "> " nicht automatisch?
2.02 Warum legt OE öfter eine Pause ein?
2.03 Warum funktioniert die Rechtschreibprüfung nicht?
2.04 Warum speichert OE das Kennwort nicht?
2.05 Warum sind die Newsgroups nach dem Beenden von OE verschwunden?
2.06 Warum löscht OE News früher als eingestellt?
2.07 Warum stürzt OE ab oder startet nicht?
2.08 Warum legt OE nach dem Senden & Empfangen nicht auf?
2.09 Warum erscheint mein Posting nicht in OE?
2.10 Warum werden Mails/News gar nicht oder nur als Attachments angezeigt?
2.11 Warum klappt das mit den Anhängen nicht?
2.12 Warum ist mein Adressbuch/meine Kontaktliste leer?
2.13 Warum kann ich keine Emails verschicken?
2.14 Warum werden OE4-Mails von OE5/6 nicht importiert?
2.15 Warum zeigt OE (manche) *Bilder* nicht an?
2.16 Warum ist meine Zeile x zu lang?
2.17 Warum öffnet OE keine Links mehr?

3.0 Wie kann ich...?
3.01 Wie kann ich OE als Standardprogramm für E-Mails/News einrichten?
3.02 Wie kann ich den Download von E-Mails *und* News automatisieren?
3.03 Wie kann ich E-Mails automatisch in bestimmte Ordner umleiten?
3.04 Wie kann ich Newsregeln nutzen?
3.05 Wie kann ich Dateianlagen aus E-Mails löschen?
3.06 Wie kann ich die Datenbanken für E-Mails und News verkleinern?
3.07 Wie kann ich das Speicherverzeichnis für E-Mails/News ändern?
3.08 Wie kann ich ein Backup von E-Mail/News anlegen und wiederherstellen?
3.09 Wie kann ich in E-Mail/News eine Signatur einfügen?
3.10 Wie kann ich einen eigenen Beitrag vom News-Server löschen (canceln)?
3.11 Wie kann ich die Anzeigeschriftart ändern?
3.12 Wie kann ich den Begrüßungsbildschirm (SplashScreen) abschalten?
3.13 Wie kann ich von Mails nur die Kopfdaten herunterladen (Remote-Mail)?
3.14 Wie kann ich OE mit bestimmten Optionen starten?
3.15 Wie kann ich eigene Kopf- (Header-) Zeilen in Nachrichten erstellen?
3.16 Wie kann ich E-Mails/News nicht über das Standard-Konto versenden?
3.17 Wie kann ich PGP in OE einbinden?
3.18 Wie kann ich das Editor-Fenster automatisch maximieren?
3.19 Wie kann ich meinen POP3-Account vor dem Senden abfragen ("SMTP after POP")?
3.20 Wie kann ich den Einleitungstext ändern? (das "in im"-Problem)
3.21 Wie kann ich einen "Watch-Filter" auf eigene Postings einrichten?
3.22 Wie kann ich OE mit verschiedenen Identitäten starten?
3.23 Wie kann ich das Euro-Währungssymbol korrekt verschicken?
3.24 Wie kann ich OE (viren-)sicher einstellen und betreiben?
3.25 Wie kann ich Emails/News mit OE erneut versenden?
3.26 Wie kann ich mit Message-Ids arbeiten?
3.27 Wie kann ich die die Einstellungen beim Drucken ändern?
3.28 Wie kann ich die Kontakte in OL und OE gemeinsam verwenden?

4.0 Nachbemerkungen
4.01 Fehlernummern
4.02 Artikel der MS Knowledge Base
4.03 Schutz gegen Spam (UCE/Bulk-Mail, etc.)
4.04 Hotmail-Problematik
4.05 Synchronisationseinstellungen
4.06 Was OE sonst noch alles kann (Registryoptionen)
4.07 Bekannte Probleme und Bugs

5.0 Schlußbemerkung

OE 5 und 6-FAQ > 2.10 Warum werden Mails/News gar nicht oder nur als Attachments angezeigt?
2.10 Warum werden Mails/News gar nicht oder nur als Attachments angezeigt?
Zwei ähnliche Probleme mit ähnlichen, aber nicht immer gleichen Lösungsmöglichkeiten (der Kopf der Nachricht wird in der Übersicht jeweils angezeigt):
Nachrichtentext leer, kein (vom Absender nicht beabsichtigter) Anhang vorhanden:
  • Zunächst kann man probieren, ob die Nachrichten angezeigt werden, wenn man sie im EML/NWS-Format auf die Festplatte abspeichert und dann von dort öffnet. Falls ja, sollte man in OE Datei | Ordner | Alle Ordner komprimieren laufen lassen, um die Datenbank der Nachrichten aufzuräumen. Hilft dies bereits, sollte man sich #2.07 anschauen...

  • Temporary Internet Files ("TIF") löschen. Sämtliche Hintergrundprogramme schließen, ebenso IE und OE. Systemsteuerung | Internetoptionen aufrufen und dort die TIF einschließlich Offlineinhalten leeren. Alternativ bei Win9x: TIF-Verzeichnis unter reinem DOS komplett löschen. Windows darf nicht im Hintergrund laufen, smartdrv, deltree tempor~1, das Verzeichnis wird automatisch wieder erstellt. bzw. bei NT-basierten Windows: Vom (echten) Admin-Profil aus einfach das komplette TIF-Verzeichnis des betroffenen Benutzers löschen.

  • Daneben sollte man sicherstellen, dass ein existierendes Temp-Verzeichnis eingestellt ist, auf das der Benutzer auch Schreibrechte hat (kann man dort Dateien abspeichern?). Sind die Umgebungsvariablen TMP bzw. TEMP beispielsweise auf einen nicht-existenten Pfad gestellt, verweigert OE komplett die Anzeige des Inhalts von Mails und News, das Nachrichtenfenster bleibt schlicht leer (über [Strg.]&[F3] lässt sich der Inhalt der Nachrichten allerdings trotzdem anzeigen).

  • Sollte man von Verisign/IDNnow (dieses ist auch bei der Denic verlinkt) ein PlugIn installiert haben, um auf IDNs (Umlautdomains) zuzugreifen: Dieses probeweise deinstallieren und neu starten, es gab hierbei ein bekanntes Problem, das sich genau dadurch äußerte, dass OE keine Nachrichten mehr anzeigt. Hilft die Deinstallation und möchte man weiterhin Umlautdomains über ihren Umlautnamen und nicht im Punycode ansprechen: Die *aktuellste* Version des Programms herunterladen und installieren.

  • Wenn alles nichts hilft, kann man die für die Darstellung noch mitverantwortliche INETCOMM.DLL erneut registieren, womöglich wurde der Eintrag von irgendeinem Tool oder Programm beschädigt. Dazu sämtliche IE-, OE-, Mail-, News- und Explorerfenster schließen (am besten alle Programme beenden) und bei Start | Ausführen dann "regsvr32 inetcomm.dll" (ohne Anführungszeichen!) eingeben und mit OK aufrufen. Es sollte eine Erfolgsmeldung erscheinen (DllRegisterServer in inetcomm.dll succeeded). Hintergrund: Wird diese DLL während OE läuft deregistriert zeigt OE den Inhalt von Nachrichten nicht mehr an bis sie wieder registriert ist.

  • Wer McAfee einsetzt, sollte ggf. den "Internetfilter" deaktivieren.

Nachrichtentext leer (Kopf wird angezeigt), aber Inhalt über Anhangsbüroklammer zugänglich:

Wenn man Mails oder News lesen möchte, erscheint das Vorschaufenster bei diesem Problem leer (Betreff, etc. wird angezeigt, aber kein Inhalt), obwohl Text vorhanden ist. Der Inhalt der Nachricht kann über die Attachmentfunktion (Büroklammersymbol) geöffnet werden, ebenso wie er im Quelltext vorhanden ist ([Strg.]&[F3]). Das ganze betrifft alte, bereits gelesene, aber auch neue Nachrichten.

Was die exakte Ursache dafür ist, steht nicht fest, aber es ist sehr wahrscheinlich, dass die automatische Komprimierung im Hintergrund (unter Windows XP SP2 aus gutem Grund entfernt) etwas damit zu tun hat (abschalten - siehe #2.07) und auch die zusätzliche Ablage der Nachrichten beim Öffnen in den TIF höchstwahrscheinlich beteiligt ist. Folgende Lösungsmöglichkeiten setzen dem Spuk meist schnell wieder ein Ende:
  • Temporary Internet Files ("TIF") löschen. Sämtliche Hintergrundprogramme schließen, ebenso IE und OE. Systemsteuerung | Internetoptionen aufrufen und dort die TIF einschließlich Offlineinhalten leeren. Alternativ bei Win9x: TIF-Verzeichnis unter reinem DOS komplett löschen. Windows darf nicht im Hintergrund laufen, smartdrv, deltree tempor~1, das Verzeichnis wird automatisch wieder erstellt. bzw. bei NT-basierten Windows: Vom (echten) Admin-Profil aus einfach das komplette TIF-Verzeichnis des betroffenen Benutzers löschen.

    Daneben sollte man sicherstellen, dass ein Temp-Verzeichnis vorhanden ist, auf das der Benutzer auch Schreibrechte hat (kann man dort Dateien abspeichern?).

  • Manchmal hilft auch schon Datei | Ordner | Alle Ordner komprimieren; bitte die Hinweise zur schlecht arbeitenden Hintergrundkomprimierung bei #2.07 beachten.

  • Eine weitere, effektive Möglichkeit ist die Reparieren-Funktion der IE-Installation, die allerdings nur zur Verfügung steht, wenn man auf dem betroffenen Windows bereits einen neueren als den mitgelieferten IE installiert hat. Sämtliche (Hintergrund-)Programme schließen und dann Systemsteuerung | Software | Microsoft Internet Explorer 5/6 und Internettools | Hinzufügen/Entfernen | Reparieren aufrufen. Anschließend Windows neu starten.
Um zu vermeiden, dass das Problem erneut auftritt, sollte man die automatische Komprimierung im Hintergrund (s.o.) deaktivieren (Extras | Optionen | Wartung) und stattdessen regelmäßig händisch den Komprimierungsvorgang über Datei | Ordner | Alle Ordner komprimieren starten. Mehr dazu bei #2.07.